Shuffling is a procedure used to randomize a deck of playing cards. Because standard shuffling techniques are seen as weak, and in order to avoid “inside jobs” where employees collaborate with gamblers by performing inadequate shuffles, many casinos employ automatic shuffling machines. Your task is to simulate a shuffling machine.
The machine shuffles a deck of 54 cards according to a given random order and repeats for a given number of times. It is assumed that the initial status of a card deck is in the following order:
S1, S2, , S13,
H1, H2, , H13,
C1, C2, , C13,
D1, D2, , D13,
J1, J2
where “S” stands for “Spade”, “H” for “Heart”, “C” for “Club”, “D” for “Diamond”, and “J” for “Joker”. A given order is a permutation of distinct integers in [1, 54]. If the number at the i-th position is j, it means to move the card from position i to position j. For example, suppose we only have 5 cards: S3, H5, C1, D13 and J2. Given a shuffling order {4, 2, 5, 3, 1}, the result will be: J2, H5, D13, S3, C1. If we are to repeat the shuffling again, the result will be: C1, H5, S3, J2, D13.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer K (≤20) which is the number of repeat times. Then the next line contains the given order. All the numbers in a line are separated by a space.
Output Specification:
For each test case, print the shuffling results in one line. All the cards are separated by a space, and there must be no extra space at the end of the line.
Sample Input:
2
36 52 37 38 3 39 40 53 54 41 11 12 13 42 43 44 2 4 23 24 25 26 27 6 7 8 48 49 50 51 9 10 14 15 16 5 17 18 19 1 20 21 22 28 29 30 31 32 33 34 35 45 46 47
Sample Output:
S7 C11 C10 C12 S1 H7 H8 H9 D8 D9 S11 S12 S13 D10 D11 D12 S3 S4 S6 S10 H1 H2 C13 D2 D3 D4 H6 H3 D13 J1 J2 C1 C2 C3 C4 D1 S5 H5 H11 H12 C6 C7 C8 C9 S2 S8 S9 H10 D5 D6 D7 H4 H13 C5


#include< stdio.h>
#include< string.h>
int main()
{
    int n = 0, t = 0;
    scanf("%d", &n);
    char str[55][4], strs[55][4];//2个数组,一个用来临时存放
    for (int x = 1; x <= 54; x++)
        memset(str[x], '\0', sizeof(str[x]));//
    for (int x = 1; x <= 52; x++)//创建这个规则的扑克牌
    {
        t = (x - 1) / 13;
        if (x % 13 < 10 && x % 13 > 0)str[x][1] = x % 13 + 48;
        if (x % 13 >= 10)
        {
            str[x][1] = '1';
            str[x][2] = x % 13 + 48 - 10;
        }
        if (x % 13 == 0)
        {
            str[x][1] = '1';
            str[x][2] = '3';
        }
        switch (t)
        {
        case 0: str[x][0] = 'S'; break;
        case 1: str[x][0] = 'H'; break;
        case 2: str[x][0] = 'C'; break;
        case 3: str[x][0] = 'D'; break;
        }
    }
    strcpy(str[53], "J1");
    strcpy(str[54], "J2");
    int arry[55];
    for (int x = 1; x <= 54; x++)
        scanf("%d", &arry[x]);
    for (int x = 1; x <= n; x++)//简单的桶排的小变形
    {
        for (int y = 1; y <= 54; y++)
            memset(strs[y], '\0', sizeof(strs[y]));
        for (int t = 1; t <= 54; t++)
            strcpy(strs[arry[t]], str[t]);
        for (int y = 1; y <= 54; y++)
            strcpy(str[y], strs[y]);//将str更新而不必要互相更新
    }
    for (int y = 1; y <= 53; y++)
        printf("%s ", str[y]);
    printf("%s", str[54]);//不需要再之前的if语句
    return 0;
}

题目分析

题目难点主要是
1.创建这个扑克的数组
2.洗牌次数

总结和反思

1.创建这个扑克牌所写的太长,可以 用c++的string类型,直接手动数组输入
2.将str更新,而不是将str和strs交替互相更新(洗一次放入str,再洗一次放入strs,巨麻烦)
3.输出最后一个数没有空格,直接跳出循环,不要用if(y!=54)了