一个数组A中存有N(>0)个整数,在不允许使用另外数组的前提下,将每个整数循环向右移M(最后M个数循环移至最前面的M个位置)。如果需要考虑程序移动数据的次数尽量少,要如何设计移动的方法?
输入格式:
每个输入包含一个测试用例,第1行输入N(1≤N≤100)和M(≥0);第2行输入N个整数,之间用空格分隔。
输出格式:
在一行中输出循环右移M位以后的整数序列,之间用空格分隔,序列结尾不能有多余空格。
输入样例:
6 2
1 2 3 4 5 6
输出样例:
5 6 1 2 3 4

注意此题N与M大小关系都有可能存在

常规思维


#include< stdio.h>
int main()
{
    int N, M;
    scanf("%d %d", &N, &M);
    int arry[101];
    for (int x=1; x <= N; x++)
        scanf("%d", &arry[x]);
    while (M >= N)M -= N;//M是有可能大于N的
    for (int x = N - M + 1; x <= N; x++)
    {
        if (M == 0 && x == N)
            printf("%d", arry[x]);
        else
            printf("%d ",arry[x]);
    }
    for (int x = 1; x <= N - M; x++)
    {
        printf("%d", arry[x]);
        if (x != N - M)printf(" ");
    }
    return 0;
}

总结

通过改变输出的方式,“伪” 改成数组右移

动态数组


#include< stdio.h>
#include< stdlib.h>

int main()
{
int N, M, * arry;
scanf(“%d %d”, &N, &M);
arry = (int*)malloc((N + 1) * sizeof(int));
M = M % N;
for (int x = M + 1; x <= N; x++)
scanf(“%d”, &arry[x]);
for (int x = 1; x <= M; x++)
scanf(“%d”, &arry[x]);
for (int x = 1; x <= N; x++)
{
if (x != N)printf(“%d “, arry[x]);
else printf(“%d”, arry[x]);
}
return 0;
}

总结

这个做法主要突出动态数组来创建数组和非常规的输入完成所需要的输出
取模操作来确定实际的移动